Back to overview
Downtime
Confirmo Pay is unavailable because of an infrastructure issue
Jul 30 at 09:18am CEST
Affected services
Dashboard
API
Invoices
Payouts
Resolved
Jul 30 at 09:50am CEST
All services fully recovered.
Affected services
Created
Jul 30 at 09:18am CEST
We have a major infrastructure issue with our core services.
Affected services